EVO Sporty problem

Moderator: Moderators

Post Reply
User avatar
Webmaster
Site Admin
Posts: 303
Joined: Thu Nov 30, 2006 8:32 pm
Contact:

EVO Sporty problem

Post by Webmaster » Sun May 14, 2017 1:13 pm

Here's the issue....
Bike runs rough at times, other times no problem at all. Every once in awhile, it gets a lot worse. Pops through the carb, no power, goes away as fast as it comes on.

Plugs look like new when you pull them, no oil on them. Pulled fuel line, gas runs clear out of the tank. Pulled the fuel bowl off the carb, it looks so clean, you could eat out of it. Blew out all the passages, checked the float needle and the jets, everything looks good. Same issue.

User avatar
chrisrr
Posts: 1767
Joined: Mon Nov 24, 2008 12:16 pm
Location: New Lothrop, MI.

Re: EVO Sporty problem

Post by chrisrr » Thu May 18, 2017 4:51 pm

Sound kind of like an exhaust valve is hanging up. Maybe sticking on the guide, tappet might have some crud in it restricting oil flow, or the canutinary valve or wiper compression.

User avatar
Webmaster
Site Admin
Posts: 303
Joined: Thu Nov 30, 2006 8:32 pm
Contact:

Re: EVO Sporty problem

Post by Webmaster » Sun May 28, 2017 1:46 pm

he sold the bike

QUEENCAT
Posts: 4
Joined: Tue Oct 24, 2017 11:07 pm

Re: EVO Sporty problem

Post by QUEENCAT » Mon Oct 30, 2017 5:34 pm

I had that problem with my EVO, check n replace the carbi seal.....if its still doing the same, change the COIL to a High Performance. That solved it for mine....good luck
Cat

User avatar
terryzone
Site Admin
Posts: 2009
Joined: Mon Dec 01, 2008 11:37 am
Location: Latham Illinois
Contact:

Re: EVO Sporty problem

Post by terryzone » Tue Oct 31, 2017 8:42 am

Well selling it fixed that problem right off ! Gahilk
We're surrounded by idiots.

User avatar
Ripper®
Posts: 76
Joined: Thu Jan 03, 2013 10:13 pm
Location: LI, NY
Contact:

Re: EVO Sporty problem

Post by Ripper® » Tue Oct 31, 2017 2:11 pm

Easiest fix ever......

Post Reply